WordPress 5.7: actualización jQuery

¡El núcleo de WordPress está dando el salto de jQuery 1.12.4 a jQuery 3.5.1! Esto es importante por muchas razones, como características modernas, mejor DX y mejoras de seguridad, por nombrar algunas. En este momento, el plan es lanzar la actualización en WordPress 5.7, que se lanzará el 9 de marzo

WordPress es conocido por su compatibilidad con versiones anteriores y se podría decir que este cambio es una reliquia de esa filosofía. Se ha trazado una línea en la arena cuando se trata de jQuery, y 1.x no es parte de los planes para avanzar. Pero también representa un cambio radical, y eso es algo raro en el mundo de WordPress. Debido a que WordPress se envía con jQuery instalado, muchos desarrolladores llaman a esa versión en lugar de reinstalarlo en otra ubicación. Eso incluye muchos desarrolladores de temas y complementos, todos los cuales ahora deben asegurarse de que su código sea compatible con jQuery 3.x.

No hacerlo podría resultar en lotes en sitios bloqueados. Pero, oye, nos queda alrededor de un mes para trabajar en ello, ¿verdad?

El cambio ha estado en proceso durante algún tiempo. El trabajo comenzó en WordPress 5.5 y 5.7 es técnicamente la tercera de tres fases. WordPress 5.6 es donde el Core Team mejoró jQuery a la versión 3.5.1 y actualizó jQuery Migrate para ayudar a los desarrolladores a volver a jQuery heredado, si es necesario. En otras palabras, este ha sido un enfoque súper metódico. El Core Team merece muchas felicitaciones por eso, incluidas todas las comunicaciones que se han emitido sobre el cambio.

La clave es comenzar a probar ahora en WordPress 5.6. El plan es deshabilitar jQuery Migrate en WordPress 5.7, por lo que esperar ese lanzamiento es demasiado tarde. Si espera tanto y encuentra problemas, es probable que su mejor camino a seguir sea retroceder a 5.6 de todos modos para aprovechar jQuery Migrate y el complemento auxiliar.

Actualizaciones del boletín

Ingrese su dirección de correo electrónico a continuación para suscribirse a nuestro boletín